icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.a-haktransport.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

积分彩彩票 www.710658.com-最值收藏彩票| www.237439.com-中竞彩网首页| www.133044.com-纸箱彩印与覆膜| www.151826.com-时彩族人工计划| www.902409.com-彩79软件-| www.990026.com-旺彩3d开奖下载| www.bt38.com-彩票代投-| www.8279.loan-彩之源用户注册| www.026679.com-13彩票-| www.594240.com-七彩视界下载安装| www.933829.com-彩票什么方法买号准| www.50og.com-买足彩下什么软件| www.895039.com-怎么投资彩票赚钱| www.193561.com-中原彩票三d| www.980226.com-cp12彩票软件| www.fp74.com-福彩3d有规律吗| www.w18.com-长春彩溢2019| www.94dv.com-万易彩票正式上线| www.611066.cc-彩38彩票官网登录| www.712600.com-齐鲁彩票开奖号吗| www.809322.com-体彩飞鱼选号技巧| www.896307.com-9购彩下载-| www.997542.com-328彩票-| www.ls84.com-app微彩网-| www.1sw.cc-头奖彩票怎么处理了| www.70ht.com-快钱彩app安全吗| www.135044.com-五彩缤纷香烟价格| www.0431.love-彩票网站开发多少钱| www.53726.cc-时时彩官方开奖查询| www.32xi.com-彩票快彩脚本| www.5790.biz-足彩6场3关啥意思| www.89cq.com-今晚彩票开了什么| www.7667.me-福利彩票大全图九| www.39351.cc-富华彩票-| www.83983.com-七乐彩杀号公式大全| www.039108.com-双色球购彩车| www.296390.com-甘肃快三微信群号| www.995415.com-华彩网站是不是假的| www.vx89.com-大发快三能赢钱吗| www.641668.com-彩票最上面的序列号| www.766374.com-浙江福彩3d开奖| www.874186.com-七乐彩300期走势| www.978781.com-好彩高手论-| www.wv58.com-彩票下注-| www.313100.com-彩客网比分直播| www.093192.com-快三实时走势图| www.526695.com-彩发发软件真的准吗| www.687850.com-极速彩app-| www.772091.com-大通彩票官方下载| www.50eb.com-烟台福彩中心网站| www.1783.vip-台湾基诺彩开奖| www.8698.bid-七乐彩票中奖| www.55358.cc-时时彩平刷做号技巧| www.99347.com-竞彩258合法吗| www.nn48.com-nba竞彩软件| www.952288.com-中奖彩票app| www.cp401.com-大发快三平台网址| www.pp99.cc-彩涂铝板-| www.033988.com-七乐彩网站合法吗| www.175303.com-网上彩票-| www.08460.com-彩票平刷方法| www.565852.com-河南体彩481奖金| www.652288.com-福彩3d类型-| www.720050.com-快赢彩票网址| www.791853.com-福彩数字3是3d么| www.860642.com-彩800app-| www.924953.com-全民赢彩票苹果版| www.975414.com-七星彩出号口诀| 博友彩www.996732.com| www.g57.xyz-星彩论坛3d-| www.206644.com-神舟彩票登录| www.36689.cc-梦见一组彩票号码| www.171050.com-玩彩票一天赚一两千| www.297075.com-快乐彩开奖图| www.8041.xyz-87彩店客服电话| www.58112.cc-彩迷葫芦第西瓜视频| www.035986.com-五分时时彩相关软件| www.9868.cc-三杯体彩福彩| www.351015.com-鸿运彩票能玩吗| www.433218.com-中国购彩网骗人的| www.518108.com-西安福利彩票事件| www.577297.com-快三要害死人的| www.636806.com-彩虹儿歌幼儿园| www.074726.com-天不彩彩富网| www.196866.com-华人彩票网靠谱吗| www.341481.com-福彩店广告语| www.423591.com-3d星彩论坛-| www.526785.com-澳客竞彩网比分直播| www.685539.com-福彩3d任意和查表| www.752351.com-网上买彩票安全吗| www.562527.com-重庆快三真假| www.625387.com-开心彩骗局-| www.jc13.com-中国体育彩足彩开票| www.30wj.com-彩虹岛手游叫什么| www.065898.com-彩库宝典下载并安装| www.078.bid-手机足彩分析软件| www.04bx.com-彩票网购平台| www.201164.com-快三半顺是什么样的| www.261273.com-彩票vip系统查询| www.322433.com-竞彩8串8-| www.384211.com-怎么进入彩票数据库| www.758676.com-中彩网视频频道| www.668816.cc-福彩3b多彩网| www.761293.com-宝马彩票集团网址| www.831020.com-77彩票网址大全| www.919397.com-宏图娱乐彩票骗局| www.977289.com-河南的彩礼害死人| www.cp5582.com-快三和值三角图| www.ro38.com-梦想彩票安卓版下载| www.9zd.cc-七彩祥云是什么征兆| www.sr39.com-168彩票网香港彩| www.762832.com-大发购彩网-| www.879371.com-福利体彩分类| www.940445.com-快三平台真假| www.985245.com-全民福彩真的吗| www.02ul.com-广西快三多少期| www.80ll.com-彩票客服招聘| www.785278.com-广西彩民中奖一亿| www.061606.com-彩客竞彩彩票| www.0158.pw-彩色的特征包括| www.6073.biz-釉上彩简单图案| www.1038.cc-江苏快三解绑银行卡| www.957789.com-彩乐透官方app| www.137234.com-用彩泥做冰淇淋| www.273222.com-体彩公益宗旨| www.9149.cc-福利彩用户注册| www.222461.com-彩票长龙是什么意思| www.2589.cm-彩票数字拾取算法| www.138137.com-福利彩票摇号器| www.357110.com-中彩票给的是现金吗| www.191936.com-北京快三选号助手| www.848365.cc-快三和值中奖表| www.919957.com-彩名堂ios下载| www.979401.com-网络快三私彩诈骗| www.tc8.com-吉林福彩3d走势图| www.pz02.com-278彩票-| www.x80.cc-8亿彩有多少人玩过| www.0917.hk-中国福利彩票体彩| www.6251.top-彩票人为控制| www.06712.com-彩票海报图片手绘图| www.38393.cc-505彩网正规吗| www.801358.com-13彩软件-| www.875797.com-彩票彩票2元网| www.8tv.com-彩票那个软件好用| www.67bt.com-信彩票是真的吗| www.3497.org-彩票2等奖-| www.7911.cn-彩票猫腻最大的是| www.16627.cc-万彩网官网-| www.65962.cc-玩快三输了怎样解决| www.009164.com-福体彩藏机图谜字谜| www.081057.com-彩票中奖有什么规律| www.8868.org-竞彩交税-| www.62653.cc-今晚七星彩开码结果| www.97850.com-买时时彩软件| www.um80.com-体彩7位数中奖规则| www.9gw.cc-体彩中5个数多少钱| www.51bi.com-1分彩什么玩法| www.091023.cc-众彩网软件怎么下载| www.220835.com-快三定胆技巧大全| www.233701.com-彩票回补几率负| www.345171.com-彩云宝螺-| www.rk96.com-彩票大小走势怎么看| www.301200.com-下载南方双彩软件| www.501256.com-易彩堂属于哪个公司|